Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / perl / podlators-perl_4.12.bb
1
2 SUMMARY = "format POD source into various output formats"
3 DESCRIPTION = "\
4   podlators contains Pod::Man and Pod::Text modules which convert POD input \
5   to *roff source output, suitable for man pages, or plain text. It also \
6   includes several subclasses of Pod::Text for formatted output to terminals \
7   with various capabilities. It is the source package for the Pod::Man and \
8   Pod::Text modules included with Perl. \
9 "
10 HOMEPAGE = "https://www.eyrie.org/~eagle/software/podlators"
11
12 SECTION = "libs"
13
14 LICENSE = "Artistic-1.0 | GPL-1.0+"
15 LIC_FILES_CHKSUM = "file://LICENSE;md5=a25b3c873fe34dc2909a5b1ca2de4048"
16
17 CPAN_PACKAGE = "podlators"
18
19 SRC_URI = "${CPAN_MIRROR}/authors/id/R/RR/RRA/${CPAN_PACKAGE}-${PV}.tar.gz"
20
21 SRC_URI[md5sum] = "99d5b0c15d2f72c5218dce1a5a9448c5"
22 SRC_URI[sha256sum] = "948717da19630a5f003da4406da90fe1cbdec9ae493671c90dfb6d8b3d63b7eb"
23
24 S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
25
26 inherit cpan
27
28 RDEPENDS_${PN} = " \
29     perl-module-encode \
30     perl-module-pod-simple \
31 "
32
33 BBCLASSEXTEND = "native nativesdk"