Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / perl / pathtools-perl_3.75.bb
1
2 SUMMARY = "Tools for working with directory and file names"
3 DESCRIPTION = "\
4   Modules included: \
5     - Cwd - get pathname of current working directory \
6     - File::Spec - portably perform operations on file names \
7     - File::Spec::AmigaOS - File::Spec for AmigaOS \
8     - File::Spec::Cygwin - methods for Cygwin file specs \
9     - File::Spec::Epoc - methods for Epoc file specs \
10     - File::Spec::Functions - portably perform operations on file names \
11     - File::Spec::Mac - File::Spec for Mac OS (Classic) \
12     - File::Spec::OS2 - methods for OS/2 file specs \
13     - File::Spec::Unix - File::Spec for Unix, base for other File::Spec modules \
14     - File::Spec::VMS - methods for VMS file specs \
15     - File::Spec::Win32 - methods for Win32 file specs \
16 "
17 HOMEPAGE = "https://metacpan.org/release/PathTools"
18
19 SECTION = "libs"
20
21 LICENSE = "Artistic-1.0 | GPL-1.0+"
22 LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8"
23
24 CPAN_PACKAGE = "PathTools" 
25
26 SRC_URI = "${CPAN_MIRROR}/authors/id/X/XS/XSAWYERX/${CPAN_PACKAGE}-${PV}.tar.gz"
27
28 SRC_URI[md5sum] = "8f329058f74468a576442d841c62aa62"
29 SRC_URI[sha256sum] = "a558503aa6b1f8c727c0073339081a77888606aa701ada1ad62dd9d8c3f945a2"
30
31 S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
32
33 inherit cpan
34
35 RDEPENDS_${PN} = " \
36     perl-module-carp \
37     perl-module-file-basename \
38     perl-module-scalar-util \
39     perl-module-test-more \
40 "
41
42 BBCLASSEXTEND = "native nativesdk"