Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-devtools / json-c / json-c_0.11.bb
1 SUMMARY = "C bindings for apps which will manipulate JSON data"
2 DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3 HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4 LICENSE = "MIT"
5 LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
7 SRC_URI = "\
8     https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
9     file://json-c-CVE-2013-6371.patch \
10     file://json-c-Add-FALLTHRU-comment-to-handle-GCC7-warnings.patch \
11 "
12 SRC_URI[md5sum] = "aa02367d2f7a830bf1e3376f77881e98"
13 SRC_URI[sha256sum] = "28dfc65145dc0d4df1dfe7701ac173c4e5f9347176c8983edbfac9149494448c"
14
15 RPROVIDES_${PN} = "libjson"
16
17 PARALLEL_MAKE = ""
18
19 inherit autotools
20
21 do_configure_prepend() {
22     # Clean up autoconf cruft that should not be in the tarball
23     rm -f ${S}/config.status
24 }
25
26 BBCLASSEXTEND = "native nativesdk"