Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-dbs / influxdb / influxdb_0.9.5.1.bb
1 #
2 ## Copyright (C) 2019 Wind River Systems, Inc.
3 #
4 #  Licensed under the Apache License, Version 2.0 (the "License");
5 #  you may not use this file except in compliance with the License.
6 #  You may obtain a copy of the License at
7 #
8 #      http://www.apache.org/licenses/LICENSE-2.0
9 #
10 #  Unless required by applicable law or agreed to in writing, software
11 #  distributed under the License is distributed on an "AS IS" BASIS,
12 #  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
13 #  See the License for the specific language governing permissions and
14 #  limitations under the License.
15
16 SUMMARY = "InfluxDB is an open source time series platform"
17 DESCRIPTION = "\
18 InfluxDB is an open source time series platform. \
19 This includes APIs for storing and querying data, \
20 processing it in the background for ETL or monitoring \
21 and alerting purposes, user dashboards, and visualizing \
22 and exploring the data and more. \
23 "
24 HOMEPAGE = "https://www.influxdata.com/products/influxdb-overview/"
25
26 LICENSE = "MIT"
27 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
28
29 SRC_URI = "https://s3.amazonaws.com/influxdb/${BPN}_${PV}_x86_64.tar.gz"
30 SRC_URI[md5sum] = "da0cbcc5a521adc0e588327550441fbf"
31 SRC_URI[sha256sum] = "6d660007ca207f98eb847f4abf7f3060d1e6d239deeca9beaf833455a670fdb8"
32
33 S = "${WORKDIR}//${BPN}_${PV}_x86_64"
34
35 do_install() {
36     cp -av --no-preserve=ownership ${S}/* ${D}/
37 }
38
39 INSANE_SKIP_${PN}_append = "already-stripped ldflags"