Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-integ / recipes-core / systemd / systemd-conf_241.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 inherit stx-metadata
4
5 STX_REPO = "config-files"
6 STX_SUBPATH = "systemd-config"
7
8 LICENSE_append = "& Apache-2.0"
9 LIC_FILES_CHKSUM += "\
10         file://${STX_METADATA_PATH}/files/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
11         "
12
13 do_install_append () {
14         install -d -m 0755 ${D}/${sysconfdir}/systemd
15         install -m644 ${STX_METADATA_PATH}/files/journald.conf ${D}/${sysconfdir}/systemd/journald.conf
16         chmod 644 ${D}/${sysconfdir}/systemd/journald.conf
17 }