Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-utilities / worker-utils.bb
1 DESCRIPTION  = "Initial worker node resource reservation and misc. utilities"
2 SUMMARY  = "dynamic MOTD generation"
3
4 require utilities-common.inc
5 SUBPATH0 = "utilities/worker-utils/worker-utils"
6
7 LICENSE = "Apache-2.0"
8 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10 SRC_URI += " \
11         file://0001-worker-utils-account-for-distro-PATH-differeces.patch;striplevel=4 \
12         file://0001-cpumap_functions.sh-fix-perl-experimental-feature-is.patch;striplevel=4 \
13         "
14
15 RDEPENDS_${PN}_append  = " perl systemd python bash"
16 DEPENDS += " python"
17
18 inherit python-dir systemd
19 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"
20 SYSTEMD_PACKAGES += "${PN}"
21 SYSTEMD_SERVICE_${PN} = " affine-tasks.service affine-platform.sh.service"
22
23 do_configure[noexec] = "1"
24
25 do_install() {
26
27         oe_runmake install \
28                 BINDIR=${D}/${bindir} \
29                 INITDDIR=${D}/${sysconfdir}/init.d \
30                 GOENABLEDDIR=${D}/${sysconfdir}/goenabled.d \
31                 PLATFORMCONFDIR=${D}/${sysconfdir}/platform \
32                 SYSTEMDDIR=${D}/${systemd_system_unitdir}
33 }