Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-utilities / update-motd.bb
1 DESCRIPTION  = "dynamic MOTD generation"
2 SUMMARY  = "dynamic MOTD generation"
3
4 require utilities-common.inc
5 SUBPATH0 = "utilities/update-motd/files"
6
7 LICENSE = "Apache-2.0"
8 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10 RDEPENDS_update-motd  += " cronie bash"
11
12
13 do_configure[noexec] = "1"
14 do_compile[noexec] = "1"
15
16 do_install() {
17
18         install -d ${D}/${sbindir}
19         install -m 700 motd-update ${D}/${sbindir}/motd-update
20
21         install -m0755 -d ${D}/${sysconfdir}
22         install -m0755 -d ${D}/${sysconfdir}/motd.d
23
24         install -m 755 motd-header ${D}/${sysconfdir}/motd.d/00-header
25         install -m 755 motd-footer ${D}/${sysconfdir}/motd.d/99-footer
26         install -m 644 motd.head ${D}/${sysconfdir}/motd.d/motd.head
27
28         install -m0755  -d ${D}/${sysconfdir}/cron.d
29         install -m 600 motd-update.cron ${D}/${sysconfdir}/cron.d/motd-update
30         install -m 700 customize-banner ${D}/${sbindir}/customize-banner
31         install -m 700 apply_banner_customization ${D}/${sbindir}/apply_banner_customization
32         install -m 700 install_banner_customization ${D}/${sbindir}/install_banner_customization
33
34 }