Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-utilities / stx-ssl.bb
1 DESCRIPTION = " Wind River Security"
2
3 require utilities-common.inc
4 SUBPATH0 = "security/stx-ssl/"
5
6 LICENSE = "Apache-2.0"
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
8 RDEPENDS_${PN}_append = " bash"
9
10 do_configure[noexec] = "1"
11 do_compile[noexec] = "1"
12
13 do_install() {
14
15         openssl req -new -x509 -sha256 \
16                 -keyout self-signed-server-cert.pem \
17                 -out self-signed-server-cert.pem \
18                 -days 365 -nodes \
19                 -config server-csr.conf
20
21         install -p -d -m0755 ${D}/${sysconfdir}/ssl/private/
22         install -m0400 self-signed-server-cert.pem \
23                 ${D}/${sysconfdir}/ssl/private/self-signed-server-cert.pem 
24
25         install -p -d -m0755 ${D}/${sbindir}
26         install -m0700 ${S}/files/tpmdevice-setup ${D}/${sbindir}/tpmdevice-setup
27
28 }