Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-utilities / stx-extensions.bb
1 DESCRIPTION  = "TIS Extensions to thirdparty pkgs"
2 SUMMARY  = "TIS Extensions to thirdparty pkgs"
3
4 require utilities-common.inc
5
6 SUBPATH0 = "utilities/stx-extensions/files"
7
8 LICENSE = "Apache-2.0"
9 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
10
11 RDEPENDS_${PN}  += " systemd"
12
13 do_configure[noexec] = "1"
14 do_compile[noexec] = "1"
15
16 do_install() {
17
18         install -p -d -m 0755 ${D}/${sysconfdir}/sysctl.d
19         install -m 0644 coredump-sysctl.conf ${D}/${sysconfdir}/sysctl.d/50-coredump.conf
20
21         # Fix the systemd unitdir and the arguments for kernel.core_pattern
22         sed -i -e 's|${nonarch_libdir}/systemd|${systemd_unitdir}|' \
23                -e 's/%p/%P/' -e 's/%e/%c %h %e/' \
24                ${D}/${sysconfdir}/sysctl.d/50-coredump.conf
25
26         install -p -d -m 0755 ${D}/${sysconfdir}/systemd/coredump.conf.d
27         install -m 0644 coredump.conf ${D}/${sysconfdir}/systemd/coredump.conf.d/coredump.conf
28
29         install -p -d -m 0755 ${D}/${sysconfdir}/modules-load.d
30         install -m 0644 modules-load-vfio.conf ${D}/${sysconfdir}/modules-load.d/vfio.conf
31
32 }