Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-utilities / python-cephclient.bb
1 DESCRIPTION = " \
2 A client library in Python for Ceph Mgr RESTful plugin providing REST API \
3 access to the cluster over an SSL-secured connection. Python API is compatible \
4 with the old Python Ceph client at \
5 https://github.com/dmsimard/python-cephclient that no longer works in Ceph \
6 mimic because Ceph REST API component was removed. \
7 "
8
9 require utilities-common.inc
10 SUBPATH0 = "ceph/python-cephclient/python-cephclient"
11
12 LICENSE = "Apache-2.0"
13 LIC_FILES_CHKSUM = "file://LICENSE;md5=41687b590435621fc0676ac02c51154f"
14
15 RDEPENDS_${PN}_append = " \
16         python \
17         python-ipaddress \
18         python-six \
19         python-requests \
20         "
21
22 inherit setuptools
23
24 do_configure_prepend() {
25         rm -rf .pytest_cache
26         rm -rf python_cephclient.egg-info
27         rm -f requirements.txt
28 }