Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-utilities / nfscheck.bb
1 DESCRIPTION = "NFS Audit"
2 SUMMARY = "NFS Audit"
3
4 require utilities-common.inc
5 SUBPATH0 = "utilities/nfscheck/files/"
6
7 LICENSE = "Apache-2.0"
8 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10 RDEPENDS_${PN}_append = " bash systemd"
11
12 inherit systemd
13 SYSTEMD_PACKAGES += " nfscheck"
14 SYSTEMD_SERVICE_${PN} = "nfscheck.service"
15
16 do_configure[noexec] = "1"
17 do_compile[noexec] = "1"
18
19 do_install() {
20
21         install -d -m0755 ${D}/${bindir}
22         install -m0755 nfscheck.sh ${D}/${bindir}
23
24         install -d -m0755 ${D}/${systemd_system_unitdir}
25         install -m0644 nfscheck.service ${D}/${systemd_system_unitdir}
26 }