Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-utilities / ceph-manager.bb
1 DESCRIPTION_ceph-manager = " \
2 Handle Ceph API calls and provide status updates via alarms. \
3 Handle sysinv RPC calls for long running Ceph API operations: \
4         - cache tiering enable \
5         - cache tiering disable \
6 "
7
8
9 require utilities-common.inc
10
11 SUBPATH0 = "ceph/ceph-manager/ceph-manager"
12
13
14 LICENSE = "Apache-2.0"
15 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
16
17 RDEPENDS_${PN}_append = " sysinv"
18
19 inherit setuptools systemd
20 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"
21 SYSTEMD_PACKAGES += "${PN}"
22 SYSTEMD_SERVICE_${PN} = " ceph-manager.service"
23 SYSTEMD_AUTO_ENABLE_${PN} = "disable"
24
25 do_unpack_append() {
26     bb.build.exec_func('do_restore_files', d)
27 }
28
29 do_restore_files() {
30         cd ${S}
31         git reset ${SRCREV} ceph/ceph-manager/scripts
32         git reset ${SRCREV} ceph/ceph-manager/files
33         git checkout ceph/ceph-manager/scripts
34         git checkout ceph/ceph-manager/files
35 }
36
37 do_install_append() {
38
39         install -d -m0755 ${D}/${bindir}
40         install -d -m0755 ${D}/${sysconfdir}/init.d
41         install -d -m0755 ${D}/${sysconfdir}/logrotate.d
42         install -d -m0755 ${D}/${systemd_system_unitdir}
43
44         install -p -m0700 ${S}/ceph/ceph-manager/scripts/bin/ceph-manager ${D}/${bindir}
45         install -p -m0700 ${S}/ceph/ceph-manager/scripts/init.d/ceph-manager ${D}/${sysconfdir}/init.d
46         install -p -m0700 ${S}/ceph/ceph-manager/files/ceph-manager.logrotate ${D}/${sysconfdir}/logrotate.d
47         install -p -m0700 ${S}/ceph/ceph-manager/files/ceph-manager.service ${D}/${systemd_system_unitdir}
48 }