Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-metal / mtce-storage.bb
1 require metal-common.inc
2
3 SUBPATH0 = "mtce-storage/src/"
4
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8 SRC_URI += "file://0001-mtce-storage-dont-install-empty-directory-unless-nee.patch;striplevel=3"
9
10 RDEPENDS_${PN}_append = " \
11         bash \
12         systemd \
13         "
14
15 inherit systemd
16 SYSTEMD_PACKAGES = "${PN}"
17 SYSTEMD_SERVICE_${PN} = "goenabled-storage.service"
18 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
19
20 do_configure[noexec] = "1"
21 do_compile[noexec] = "1"
22
23 do_install() {
24         cd ${S}
25         oe_runmake buildroot=${D} \
26                 _sysconfdir=${sysconfdir} _unitdir=${systemd_system_unitdir} _datarootdir=${datadir} \
27                 install
28 }
29
30
31 FILES_${PN}_append = " ${datadir}/licenses/mtce-storage-1.0/LICENSE"
32