Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-metal / mtce-control.bb
1 require metal-common.inc
2
3 SUBPATH0 = "mtce-control/src/"
4
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8 SRC_URI += "file://0001-mtce-control-dont-install-empty-directory-unless-nee.patch;striplevel=3 \
9         file://mtce-control-fix-hardcoded-path-for-hbsAgent.patch;striplevel=3 \
10         file://mtce-control-adjust-unit-file-paths.patch;striplevel=3 \
11         "
12
13 RDEPENDS_${PN}_append = " \
14         bash \
15         systemd \
16         lighttpd \
17         qemu \
18         "
19
20 inherit systemd
21 SYSTEMD_PACKAGES = "${PN}"
22 SYSTEMD_SERVICE_${PN} = "hbsAgent.service"
23 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
24
25 do_configure[noexec] = "1"
26 do_compile[noexec] = "1"
27
28 do_install() {
29         cd ${S}
30         oe_runmake buildroot=${D} \
31                 _sysconfdir=${sysconfdir} _unitdir=${systemd_system_unitdir} _datarootdir=${datadir} \
32                 install
33 }
34
35 FILES_${PN}_append = " ${datadir}/licenses/mtce-control-1.0/LICENSE"
36