Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-metal / mtce-compute.bb
1 require metal-common.inc
2
3 SUBPATH0 = "mtce-compute/src/"
4
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8 SRC_URI += "file://0001-mtce-compute-dont-install-empty-directory-unless-nee.patch;striplevel=3"
9
10 RDEPENDS_${PN}_append += " \
11         bash \
12         systemd \
13         qemu \
14         "
15
16 inherit systemd
17 SYSTEMD_PACKAGES = "${PN}"
18 SYSTEMD_SERVICE_${PN} = "goenabled-worker.service"
19 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
20
21 do_configure[noexec] = "1"
22 do_compile[noexec] = "1"
23
24 do_install() {
25         cd ${S}/
26         oe_runmake -e buildroot=${D} \
27                 _sysconfdir=${sysconfdir} _unitdir=${systemd_system_unitdir} _datarootdir=${datadir} \
28                 install
29 }
30
31 FILES_${PN}_append = " ${datadir}/licenses/mtce-compute-1.0/LICENSE"