Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-metal / mtce-common.bb
1 require metal-common.inc
2
3 SUBPATH0 = "mtce-common/src/"
4
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8 SRC_URI += " \
9         file://mtce-common-do-not-use-which-to-check-CC.patch \
10         "
11
12 RDEPENDS_${PN}_append = " \
13         util-linux \
14         bash \
15         systemd \
16         dpkg \
17         time \
18         libevent \
19         expect \
20         json-c \
21         python-rtslib-fb \
22         fm-common \
23         "
24
25 DEPENDS_append = " \
26         fm-common \
27         libevent \
28         openssl \
29         json-c \
30         "
31
32 EXTRA_OEMAKE = ' -e build VER=0 VER_MJR=1 CCFLAGS="${CXXFLAGS} -DBUILDINFO=\"\\\"\$\$(date)\\\"\"" '
33
34 do_install_append() {
35
36         cd ${S}/
37
38         install -m 755 -d ${D}/${libdir}
39
40         install -m 644 -p -D daemon/libdaemon.a ${D}/${libdir}
41         install -m 644 -p -D common/libcommon.a ${D}/${libdir}
42         install -m 644 -p -D common/libthreadUtil.a ${D}/${libdir}
43         install -m 644 -p -D common/libbmcUtils.a ${D}/${libdir}
44         install -m 644 -p -D common/libpingUtil.a ${D}/${libdir}
45         install -m 644 -p -D common/libnodeBase.a ${D}/${libdir}
46         install -m 644 -p -D common/libregexUtil.a ${D}/${libdir}
47         install -m 644 -p -D common/libhostUtil.a ${D}/${libdir}
48
49         # mtce-common headers required to bring in nodeBase.h
50         install -m 755 -d ${D}/${includedir}
51         install -m 755 -d ${D}/${includedir}/mtce-common
52         install -m 644 -p -D common/fitCodes.h ${D}/${includedir}/mtce-common
53         install -m 644 -p -D common/logMacros.h ${D}/${includedir}/mtce-common
54         install -m 644 -p -D common/returnCodes.h ${D}/${includedir}/mtce-common
55         install -m 644 -p -D common/nodeTimers.h ${D}/${includedir}/mtce-common
56
57         # mtce-common headers required to build mtce-guest
58         install -m 644 -p -D common/hostClass.h ${D}/${includedir}/mtce-common
59         install -m 644 -p -D common/httpUtil.h ${D}/${includedir}/mtce-common
60         install -m 644 -p -D common/jsonUtil.h ${D}/${includedir}/mtce-common
61         install -m 644 -p -D common/msgClass.h ${D}/${includedir}/mtce-common
62         install -m 644 -p -D common/nodeBase.h ${D}/${includedir}/mtce-common
63         install -m 644 -p -D common/nodeEvent.h ${D}/${includedir}/mtce-common
64         install -m 644 -p -D common/nodeMacro.h ${D}/${includedir}/mtce-common
65         install -m 644 -p -D common/nodeUtil.h ${D}/${includedir}/mtce-common
66         install -m 644 -p -D common/timeUtil.h ${D}/${includedir}/mtce-common
67
68         # mtce-daemon headers required to build mtce-guest
69         install -m 755 -d ${D}/${includedir}/mtce-daemon
70         install -m 644 -p -D daemon/daemon_ini.h ${D}/${includedir}/mtce-daemon
71         install -m 644 -p -D daemon/daemon_common.h ${D}/${includedir}/mtce-daemon
72         install -m 644 -p -D daemon/daemon_option.h ${D}/${includedir}/mtce-daemon
73
74         # remaining mtce-common headers required to build mtce
75         install -m 644 -p -D common/alarmUtil.h ${D}/${includedir}/mtce-common
76         install -m 644 -p -D common/hostUtil.h ${D}/${includedir}/mtce-common
77         install -m 644 -p -D common/ipmiUtil.h ${D}/${includedir}/mtce-common
78         install -m 644 -p -D common/redfishUtil.h ${D}/${includedir}/mtce-common
79         install -m 644 -p -D common/bmcUtil.h ${D}/${includedir}/mtce-common
80         install -m 644 -p -D common/nlEvent.h ${D}/${includedir}/mtce-common
81         install -m 644 -p -D common/pingUtil.h ${D}/${includedir}/mtce-common
82         install -m 644 -p -D common/regexUtil.h ${D}/${includedir}/mtce-common
83         install -m 644 -p -D common/threadUtil.h ${D}/${includedir}/mtce-common
84         install -m 644 -p -D common/tokenUtil.h ${D}/${includedir}/mtce-common
85         install -m 644 -p -D common/secretUtil.h ${D}/${includedir}/mtce-common
86 }