Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-integ / spectre-meltdown-checker_git.bb
1 DESCRIPTION = " \
2 A shell script to tell if your system is vulnerable against the several \
3 \"speculative execution\" CVEs that were made public since 2018. \
4 "
5
6 SUMMARY = "Spectre and Meltdown Checker"
7 HOMEPAGE = "https://github.com/speed47/spectre-meltdown-checker"
8 LICENSE = "GPL-3.0"
9 LIC_FILES_CHKSUM = "file://spectre-meltdown-checker.sh;beginline=1;endline=5;md5=0113e62a200ec9a5f5ebdd7ad4329133"
10
11 SRCREV = "3d21dae16864f8e8262d7a35bd4de300452b274d"
12 SRCNAME = "spectre-meltdown-checker"
13 BRANCH = "master"
14 PROTOCOL = "https"
15 PV = "v0.43+git${SRCPV}"
16 S = "${WORKDIR}/git"
17
18 SRC_URI = "git://github.com/speed47/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
19
20 do_install() {
21         install -d -p -m 0755 ${D}/${sbindir} 
22         install -m 0644 ${S}/${SRCNAME}.sh ${D}/${sbindir}/${SRCNAME}.sh
23 }