Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-integ-kubernetes / cloud-provider-openstack.bb
1 DESCRIPTION = "cloud-provider-openstack"
2
3 STABLE = "starlingx/master"
4 PROTOCOL = "https"
5 BRANCH = "master"
6 SRCREV = "70609a3d55e5b7d2be82667fc35792505f9013c4"
7 S = "${WORKDIR}/git"
8 PV = "19.05"
9
10 LICENSE = "Apache-2.0"
11
12 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
13
14 SRC_URI = "git://opendev.org/starlingx/config.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
15
16 RDEPENDS_${PN} += " bash"
17
18 inherit systemd
19 SYSTEMD_PACKAGES += "${PN}"
20 SYSTEMD_SERVICE_${PN} = "${PN}.service"
21 # SYSTEMD_AUTO_ENABLE_${PN} = "enable"
22
23 do_configure[noexec] = "1"
24 do_compile[noexec] = "1"
25
26 do_install () {
27
28         cd ${S}/filesystem/cloud-provider-openstack/
29         install -d -m755 ${D}/${bindir}
30         install -d -m755 ${D}/${systemd_system_unitdir}
31
32         install -D -m644 files/cloud-provider-openstack.sh ${D}/${bindir}
33         install -D -m644 files/cloud-provider-openstack.service ${D}/${systemd_system_unitdir}
34
35
36 }