Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-ha / stx-ocf-scripts.bb
1 require ha-common.inc
2 SUBPATH0 = "stx-ocf-scripts/src/ocf"
3
4
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8 RDEPENDS_${PN} = " \
9         bash \
10         openstack-ras \
11         "
12
13 do_unpack_append() {
14     bb.build.exec_func('do_restore_license_file', d)
15 }
16
17 do_restore_license_file () {
18     cd ${S}
19     git reset HEAD LICENSE
20         git checkout LICENSE
21 }
22
23 do_install_append () {
24         install -d -m 755 ${D}/usr/lib/ocf/resource.d/openstack
25         install -p -D -m 755 $(find . -type f -not -path './.git/*') ${D}/usr/lib/ocf/resource.d/openstack/ 
26 }
27
28 FILES_${PN}_append = " \
29         ${libdir}/ocf/resource.d/openstack/ \
30         "