Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-gui / stx-gui.bb
1 DESCRIPTION = "stx-gui"
2
3 PACKAGES = "starlingx-dashboard"
4
5 PROTOCOL = "https"
6 BRANCH = "r/stx.3.0"
7 SRCREV = "d1c22e49a95f92e91049b96f44e685f46785977c"
8 S = "${WORKDIR}/git"
9 PV = "1.0.0"
10
11 LICENSE = "Apache-2.0"
12
13 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
14
15
16
17 SRC_URI = "git://opendev.org/starlingx/gui.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
18
19 inherit distutils python-dir
20
21 DEPENDS = "\
22         python \
23         python-pbr-native \
24         "
25
26 RDEPENDS_starlingx-dashboard += " \
27         python-django-horizon \
28         "
29
30 RDEPENDS_starlingx-dashboard_append = " \
31         ${PYTHON_PN}-cephclient \
32         "
33
34 do_configure () {
35         cd ${S}/starlingx-dashboard/starlingx-dashboard
36         distutils_do_configure
37 }
38
39
40 do_compile () {
41         cd ${S}/starlingx-dashboard/starlingx-dashboard
42         distutils_do_compile
43 }
44
45
46 do_install () {
47         cd ${S}/starlingx-dashboard/starlingx-dashboard
48         distutils_do_install
49
50         install -d -m 0755 ${D}/${datadir}/openstack-dashboard/openstack_dashboard/enabled/
51         install -d -m 0755 ${D}/${datadir}/openstack-dashboard/openstack_dashboard/themes/starlingx/
52         install -d -m 0755 ${D}/${datadir}/openstack-dashboard/openstack_dashboard/local/local_settings.d
53         cp -ra ${D}${PYTHON_SITEPACKAGES_DIR}/starlingx_dashboard/enabled/* \
54                         ${D}/${datadir}/openstack-dashboard/openstack_dashboard/enabled/
55         cp -ra ${D}${PYTHON_SITEPACKAGES_DIR}/starlingx_dashboard/themes/starlingx/* \
56                         ${D}/${datadir}/openstack-dashboard/openstack_dashboard/themes/starlingx/
57         cp -ra ${D}${PYTHON_SITEPACKAGES_DIR}/starlingx_dashboard/local/local_settings.d/* \
58                         ${D}/${datadir}/openstack-dashboard/openstack_dashboard/local/local_settings.d
59         # comment out this line with syntax error
60         sed -i -e 's|^OPENSTACK_NEUTRON_NETWORK|# &|' \
61                         ${D}/${datadir}/openstack-dashboard/openstack_dashboard/local/local_settings.d/_30_stx_local_settings.py
62 }
63
64 FILES_starlingx-dashboard = " \
65         ${PYTHON_SITEPACKAGES_DIR} \
66         ${datadir}/openstack-dashboard/openstack_dashboard \
67         "