Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-fault / fm-common.bb
1 inherit autotools
2 inherit setuptools
3
4 require fault-common.inc
5
6 SRC_URI += "file://0001-fm-common-add-LDFLAGS.patch"
7
8 SUBPATH0 = "fm-common/sources"
9 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
10
11 EXTRA_OEMAKE = '-e INCLUDES="-I./ " \
12                EXTRACCFLAGS=" " \
13                CCFLAGS="${CXXFLAGS} ${CCSHARED}" \
14                LDFLAGS="${LDFLAGS} -shared" \
15                LIBDIR=${libdir} \
16                INCDIR=${includedir} \
17                CGCS_DOC_DEPLOY=${docdir} \
18                DESTDIR=${D} \
19                BINDIR=${bindir} \
20               '
21
22 do_configure_prepend () {
23     sed -i -e 's|/usr/local/bin|${bindir}|' ${S}/fmConstants.h
24     cd ${S}
25
26
27
28 # need to build fm-common library first then setup.py can run
29 do_compile_prepend() {
30         cd ${S}
31         autotools_do_compile
32 }
33
34 do_install_prepend() {
35         cd ${S}
36         autotools_do_install
37 }