Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-distributedcloud / distributedcloud-client-dcmanager_git.bb
1 DESCRIPTION = " \
2         Client library for Distributed Cloud built on the Distributed Cloud API. \
3         It provides a command-line tool (dcmanager).  \
4         Distributed Cloud provides configuration and management of distributed clouds \
5         "
6
7 HOMEPAGE = "https://opendev.org/starlingx"
8 SECTION = "network"
9 LICENSE = "Apache-2.0"
10 LIC_FILES_CHKSUM = "file://distributedcloud-client/LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
11
12 PROTOCOL = "https"
13 BRANCH = "r/stx.3.0"
14 SRCNAME = "distcloud-client"
15 SRCREV = "8a8f01dd3701d4793dd8cbc0147e4dca49cd7c03"
16 PV = "1.0.0+git${SRCPV}"
17 S = "${WORKDIR}/git"
18
19 SRC_URI = " \
20         git://opendev.org/starlingx/${SRCNAME}.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
21         "
22
23 inherit distutils python-dir
24
25 DEPENDS += " \
26         python-pbr-native \
27         "
28
29 do_configure() {
30         cd ${S}/distributedcloud-client
31         distutils_do_configure
32 }
33
34 do_compile() {
35         cd ${S}/distributedcloud-client
36         distutils_do_compile
37 }
38
39 do_install() {
40         cd ${S}/distributedcloud-client
41         distutils_do_install
42 }