Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-config / sysinv-agent.bb
1 require config-common.inc
2
3 SUBPATH0 = "sysinv/sysinv-agent"
4
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8 SRC_URI += "file://0003-sysinv-agent-remove-legacy-pid-directory.patch;striplevel=3"
9
10 RDEPENDS_sysinv-agent += " python"
11
12 inherit systemd
13 SYSTEMD_PACKAGES += "sysinv-agent"
14 SYSTEMD_SERVICE_sysinv-agent = "sysinv-agent.service"
15 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
16
17 do_configure[noexec] = "1"
18 do_compile[noexec] = "1"
19
20 do_install_append() {
21
22
23         install -d -m 755 ${D}${sysconfdir}/init.d
24         install -p -D -m 755 ${S}/sysinv-agent ${D}/${sysconfdir}/init.d/sysinv-agent
25
26         install -d -m 755 ${D}${sysconfdir}/pmon.d
27         install -p -D -m 644 ${S}/sysinv-agent.conf ${D}/${sysconfdir}/pmon.d/sysinv-agent.conf
28         install -p -D -m 644 ${S}/sysinv-agent.service ${D}/${systemd_system_unitdir}/sysinv-agent.service
29
30 }
31