Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-config / config-gate.bb
1 PACKAGES += " config-gate-worker"
2
3 require config-common.inc
4
5 SUBPATH0 = "config-gate/files"
6
7 LICENSE = "Apache-2.0"
8 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10 RDEPENDS_config-gate-worker_append = " bash"
11 RDEPENDS_${PN}_append = " bash"
12
13
14 inherit systemd
15 SYSTEMD_PACKAGES += "${PN}"
16 SYSTEMD_PACKAGES += "${PN}-worker"
17 SYSTEMD_SERVICE_${PN} = "config.service"
18 SYSTEMD_SERVICE_config-gate-worker = "worker-config-gate.service"
19 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
20 SYSTEMD_AUTO_ENABLE_${PN}-worker = "enable"
21
22 do_configure[noexec] = "1"
23 do_compile[noexec] = "1"
24
25 do_install() {
26         oe_runmake -e \
27                  SBINDIR=${D}/${sbindir} SYSTEMDDIR=${D}/${systemd_system_unitdir} \
28                  install
29 }