Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-config / cgts-client.bb
1 require config-common.inc
2
3 SUBPATH0 = "sysinv/cgts-client/cgts-client"
4
5 LICENSE = "Apache-2.0"
6 LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8 DEPENDS += " \
9         python-pbr-native \
10         "
11
12 RDEPENDS_${PN}_append = " \
13         python-prettytable \
14         bash-completion \
15         python-neutronclient \
16         python-keystoneclient \
17         python-six \
18         python-httplib2 \
19         "
20
21 inherit setuptools
22
23 do_install_append() {
24        install -d -m 755 ${D}/${sysconfdir}/bash_completion.d
25        install -p -D -m 664 tools/system.bash_completion ${D}/${sysconfdir}/bash_completion.d/system.bash_completion
26 }