Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-flock / stx-config-files / mlx4-init.bb
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 inherit stx-metadata
4
5 STX_REPO = "config-files"
6 STX_SUBPATH = "mlx4-config"
7
8 DSTSUFX0 = "stx-configfiles"
9
10 LICENSE = "Apache-2.0"
11 LIC_FILES_CHKSUM += "\
12         file://${STX_METADATA_PATH}/centos/mlx4-config.spec;beginline=1;endline=10;md5=b791daf2e53077e3acb71428524a356d \
13         file://${STX_METADATA_PATH}/files/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
14         "
15
16 RDEPENDS_${PN}_append = " bash"
17
18 inherit systemd
19 SYSTEMD_PACKAGES += "${PN}"
20 SYSETMD_SERVICE_${PN}_append = "mlx4-config.service"
21 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
22 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"
23
24
25 do_configure[noexec] = "1"
26 do_patch[noexec] = "1"
27
28 do_install() {
29         install -d -m 0755 ${D}/${sysconfdir}/init.d/
30         install -d -m 0755 ${D}/${systemd_system_unitdir}/
31         install -d -m 0755 ${D}/${sysconfdir}/goenabled.d/
32         install -d -m 0755 ${D}/${bindir}/
33
34         install -m 755 ${STX_METADATA_PATH}/files/mlx4-configure.sh ${D}/${sysconfdir}/init.d/
35         install -m 644 ${STX_METADATA_PATH}/files/mlx4-config.service ${D}/${systemd_system_unitdir}/
36         install -m 555 ${STX_METADATA_PATH}/files/mlx4_core_goenabled.sh ${D}/${sysconfdir}/goenabled.d/
37         install -m 755 ${STX_METADATA_PATH}/files/mlx4_core_config.sh ${D}/${bindir}/
38 }
39
40 FILES_${PN}_append = " ${systemd_system_unitdir}"
41