Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-distro / recipes-security / gssproxy / gssproxy_0.7.0.bb
1
2 SUMMARY = "provides a daemon to manage access to GSSAPI credentials"
3 HOMEPAGE = "https://pagure.io/gssproxy"
4
5 LICENSE = "MIT"
6 LIC_FILES_CHKSUM = "file://COPYING;md5=a9ac3d0a983ebc781f7aa7173499e2e5"
7
8 DEPENDS += "popt ding-libs keyutils libverto krb5 libxslt-native libxml2-native \
9             libselinux libpthread-stubs gettext-native \
10             "
11 RDEPENDS_${PN} += "libinih popt libverto-libevent libverto-tevent keyutils \
12                    libgssapi-krb5 libgssrpc libk5crypto libkadm5clnt-mit \
13                    libkadm5srv-mit libkdb5 libkrad libkrb5 libkrb5support \
14                    libxslt libxslt-bin libxml2-utils libxml2 \
15                    "
16
17
18 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
19
20 SRC_URI = "https://releases.pagure.org/gssproxy/gssproxy-${PV}.tar.gz \
21       file://Properly-renew-expired-credentials.patch;striplevel=2 \
22       file://Change-impersonator-check-code.patch;striplevel=2 \
23       file://Allow-connection-to-self-when-impersonator-set.patch;striplevel=2 \
24       file://Make-proc-file-failure-loud-but-nonfatal.patch;striplevel=2 \
25       file://Turn-on-Wextra.patch;striplevel=2 \
26       file://Fix-unused-variables.patch;striplevel=2 \
27       file://Fix-mismatched-sign-comparisons.patch;striplevel=2 \
28       file://Fix-error-checking-on-get_impersonator_fallback.patch;striplevel=2 \
29       file://Remove-gpm_release_ctx-to-fix-double-unlock.patch;striplevel=2 \
30       file://Appease-gcc-7-s-fallthrough-detection.patch;striplevel=2 \
31       file://Fix-memory-leak.patch;striplevel=2 \
32       file://Fix-most-memory-leaks.patch;striplevel=2 \
33       file://Fix-segfault-when-no-config-files-are-present.patch;striplevel=2 \
34       file://Update-systemd-file.patch;striplevel=2 \
35       file://Fix-error-handling-in-gp_config_from_dir.patch;striplevel=2 \
36       file://Do-not-call-gpm_grab_sock-twice.patch;striplevel=2 \
37       file://Only-empty-FILE-ccaches-when-storing-remote-creds.patch;striplevel=2 \
38       file://Handle-outdated-encrypted-ccaches.patch;striplevel=2 \
39       file://Separate-cred-and-ccache-manipulation-in-gpp_store_r.patch;striplevel=2 \
40       file://Properly-locate-credentials-in-collection-caches-in-.patch;striplevel=2 \
41       file://Properly-initialize-ccaches-before-storing-into-them.patch;striplevel=2 \
42       file://Include-header-for-writev.patch;striplevel=2 \
43       file://Tolerate-NULL-pointers-in-gp_same.patch;striplevel=2 \
44       file://Add-Client-ID-to-debug-messages.patch;striplevel=2 \
45       file://client-Switch-to-non-blocking-sockets.patch;striplevel=2 \
46       file://server-Add-detailed-request-logging.patch;striplevel=2 \
47       file://Fix-potential-free-of-non-heap-address.patch;striplevel=2 \
48       file://Prevent-uninitialized-read-in-error-path-of-XDR-cont.patch;striplevel=2 \
49       file://Simplify-setting-NONBLOCK-on-socket.patch;striplevel=2 \
50       file://Fix-handling-of-non-EPOLLIN-EPOLLOUT-events.patch;striplevel=2 \
51       file://Fix-error-handling-in-gpm_send_buffer-gpm_recv_buffe.patch;striplevel=2 \
52       file://Emit-debug-on-queue-errors.patch;striplevel=2 \
53       file://Conditionally-reload-kernel-interface-on-SIGHUP.patch;striplevel=2 \
54       file://Don-t-leak-mech_type-when-CONTINUE_NEEDED-from-init_.patch;striplevel=2 \
55       file://Always-use-the-encype-we-selected.patch;striplevel=2 \
56       file://Clarify-debug-and-debug_level-in-man-pages.patch;striplevel=2 \
57       file://Always-choose-highest-requested-debug-level.patch;striplevel=2 \
58       "
59
60 SRC_URI[md5sum] = "1837acb5766ffbc6fcc70ecaa72e285f"
61
62 inherit autotools systemd pkgconfig
63
64 SYSTEMD_SERVICE_${PN} = "gssproxy.service"
65
66 EXTRA_OECONF="--with-pubconf-path=${sysconfdir}/gssproxy \
67               --with-initscript=systemd --disable-static \
68               --disable-rpath --with-gpp-default-behavior=REMOTE_FIRST \
69               --with-systemdunitdir=${systemd_system_unitdir} \
70               --with-manpages=no \
71               "
72
73 CFLAGS += "-fPIE -fstack-protector-all"
74 LDFLAGS += "-fPIE -pie -Wl,-z,now"
75