Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-distro / recipes-httpd / lighttpd / lighttpd_%.bbappend
1 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3 inherit stx-metadata
4
5 STX_REPO = "config-files"
6 STX_SUBPATH = "lighttpd-config"
7
8 LICENSE_append = "& Apache-2.0"
9 LIC_FILES_CHKSUM += "\
10         file://${STX_METADATA_PATH}/files/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
11         "
12
13 do_install_append () {
14     # remove the symlinks
15     rm ${D}/www/logs
16     rm ${D}/www/var
17
18     # use tmpfile to create dirs
19     install -d ${D}${sysconfdir}/tmpfiles.d/
20     echo "d /www/var 0755 www root -" > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
21     echo "d /www/var/log 0755 www root -" >> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
22
23
24     install -d -m 1777 ${D}/www/tmp
25     install -d ${D}/${sysconfdir}/lighttpd/ssl
26     install -d ${D}/www/pages/dav
27
28     install -d -m755 ${D}/${sysconfdir}/logrotate.d
29
30     install -m755 ${STX_METADATA_PATH}/files/lighttpd.init ${D}/${sysconfdir}/init.d/lighttpd
31
32     install -m640 ${STX_METADATA_PATH}/files/lighttpd.conf          ${D}/${sysconfdir}/lighttpd/lighttpd.conf
33     install -m644 ${STX_METADATA_PATH}/files/lighttpd-inc.conf      ${D}/${sysconfdir}/lighttpd/lighttpd-inc.conf
34     install -m644 ${STX_METADATA_PATH}/files/index.html.lighttpd    ${D}/www/pages/index.html
35     install -m644 ${STX_METADATA_PATH}/files/lighttpd.logrotate    ${D}/${sysconfdir}/logrotate.d/lighttpd
36
37 }
38
39 DISTRO_FEATURES_BACKFILL_CONSIDERED_remove = "sysvinit"