Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-distro / recipes-httpd / apache2 / apache2_%.bbappend
1
2
3 APACHE_PORT_NUM ?= "81"
4
5 do_install_append () {
6         sed -i -e 's/80/${APACHE_PORT_NUM}/' ${D}/${sysconfdir}/${BPN}/httpd.conf
7 }
8
9 inherit useradd
10
11 USERADD_PACKAGES = "${PN}"
12
13 USERADD_PARAM_${PN} = "-c 'Apache' -u 48 -g apache -s /sbin/nologin -r -d /usr/share/httpd apache"
14 GROUPADD_PARAM_${PN} = "-g 48 -r apache"
15
16 SYSTEMD_AUTO_ENABLE_${PN} = "disable"