Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-distro / recipes-core / images / stx-image-aio.bb
1
2 SUMMARY = " StarlingX Single Server"
3
4 LICENSE = "MIT"
5
6 CORE_IMAGE_EXTRA_INSTALL = " \
7         packagegroup-basic \
8         packagegroup-core-base-utils  \
9         "
10
11 IMAGE_INSTALL_append = " \
12         ${CORE_IMAGE_BASE_INSTALL} \
13         packagegroup-core-full-cmdline \
14         packagegroup-core-lsb \
15         packagegroup-stx-upstream \
16         packagegroup-stx-puppet \
17         packagegroup-stx-fault \
18         packagegroup-stx-metal \
19         packagegroup-stx-nfv \
20         packagegroup-stx-monitoring \
21         packagegroup-stx-ha \
22         packagegroup-stx-config-files \
23         packagegroup-stx-update \
24         packagegroup-stx-integ \
25         packagegroup-stx-config \
26         packagegroup-stx-distributedcloud \
27         packagegroup-stx-utilities \
28         packagegroup-stx-armada-app \
29         starlingx-dashboard \
30         playbookconfig \
31         distributedcloud-client-dcmanager \
32         registry-token-server \
33         rt-tests \
34         kernel-dev \
35         "
36
37 IMAGE_FEATURES += " \
38         package-management \
39         ssh-server-openssh \
40         "
41
42 inherit stx-image-list
43 inherit stx-postrun
44 inherit extrausers-config
45 inherit core-image
46 inherit distro_features_check
47 inherit openstack-base
48 inherit identity
49 inherit monitor
50
51 # We need docker-ce
52 PACKAGE_EXCLUDE += " docker"