Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-distro / classes / stx-source.bbclass
1 # This class is usd for creating source recipe for StarlingX repos,
2 # which will be used as a shared work directory with other recipes
3
4 STX_REPO ?= "integ"
5 OVERRIDES .= ":${STX_REPO}"
6
7 PROTOCOL = "https"
8 STX_URI = "git://opendev.org/starlingx/${STX_REPO}.git"
9
10 S = "${WORKDIR}/git"
11 PV = "1.0.0+git${SRCPV}"
12
13 LICENSE = "Apache-2.0"
14 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
15
16 SRC_URI = "${STX_URI};protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH}"
17
18 deltask do_configure
19 deltask do_compile
20 deltask do_install
21 deltask do_populate_sysroot
22 deltask do_populate_lic
23
24 inherit nopackages
25
26 WORKDIR = "${TMPDIR}/work-shared/${PN}"
27
28 STAMP = "${STAMPS_DIR}/work-shared/${PN}"
29 STAMPCLEAN = "${STAMPS_DIR}/work-shared/${PN}-*"
30
31 INHIBIT_DEFAULT_DEPS = "1"
32 DEPENDS = ""
33 PACKAGES = ""
34
35 EXCLUDE_FROM_WORLD = "1"
36 RM_WORK_EXCLUDE += "${PN}"