Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-distro / classes / stx-postrun.bbclass
1
2 # This class is intended to include workarounds and finetuning of the rootfs
3 # Most of the stuff in here needs to go else where.
4
5 ROOTFS_POSTPROCESS_COMMAND_append = " stx_postprocess_rootfs;"
6 # ETHDEV = "enp0s5"
7
8 stx_postprocess_rootfs() {
9
10         # Issue: #83 /dev/root does not exist
11         # This workaround is to be removed once initramfs is added
12
13         cat > ${IMAGE_ROOTFS}/etc/udev/rules.d/99-dev-root-symlink.rules << \EOF
14 KERNEL=="sda3", SYMLINK+="root"
15 EOF
16 }