Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppetlabs-mysql_git.bb
1
2 SUMMARY = "The mysql module installs, configures, and manages the MySQL service."
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7 PV = "3.11.0"
8 SRCREV = "920dd76214d87d9b26f0db105886ee89ac266c4e"
9 PROTOCOL = "https"
10 BRANCH = "main"
11 S = "${WORKDIR}/git"
12
13 SRC_URI = "git://github.com/puppetlabs/puppetlabs-mysql.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
14     file://puppetlabs-mysql/Add-gemspec.patch \
15     "
16 #   file://puppetlabs-mysql/0001-Fix-ruby-path.patch
17
18 inherit ruby
19
20 DEPENDS += " \
21         ruby \
22         facter \
23         "
24
25 RDEPENDS_${PN} += " \
26         ruby \
27         facter \
28         puppet \
29         perl \
30         "
31
32 RUBY_INSTALL_GEMS = "puppetlabs-mysql-${PV}.gem"
33
34 do_install_append() {
35         install -d -m 0755 ${D}/${datadir}/puppet/modules/mysql
36         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/mysql
37 }
38
39 FILES_${PN} += " ${datadir}"