Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppetlabs-lvm_git.bb
1
2 SUMMARY = "Provides Puppet types and providers to manage Logical Resource Management (LVM) features."
3
4 LICENSE = "GPLv2"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
6
7 PV = "0.5.0"
8 SRCREV = "d0283da637ae24550fb4ba109a48ef8d5d8c8b84"
9 PROTOCOL = "https"
10 BRANCH = "master"
11 S = "${WORKDIR}/git"
12
13 SRC_URI = "git://github.com/puppetlabs/puppetlabs-lvm;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
14         file://${PN}/Add-gemspec.patch \
15         "
16
17 inherit ruby 
18
19 DEPENDS += " \
20         ruby \
21         facter \
22         "
23
24 RDEPENDS_${PN} += " \
25         ruby \
26         facter \
27         puppet \
28         perl \
29         "
30
31 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
32
33
34 do_install_append() {
35         install -d -m 0755 ${D}/${datadir}/puppet/modules/lvm
36         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/lvm/
37 }
38
39 FILES_${PN} += " ${datadir}"