Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppetlabs-create-resources_git.bb
1
2 SUMMARY = "Function to dynamically create resources from hashes."
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=6089b6bd1f0d807edb8bdfd76da0b038 "
6
7 PV = "0.0.1"
8 STABLE = "master"
9 PROTOCOL = "https"
10 BRANCH = "master"
11 SRCREV = "4639819a7f3a4fa9310d2ba583c63e467df7e2c3"
12 S = "${WORKDIR}/git"
13
14
15 SRC_URI = " \
16         git://github.com/puppetlabs/puppetlabs-create_resources.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
17         file://${PN}/Add-gemspec.patch \
18         file://${PN}/metadata.json.patch \
19         "
20 inherit ruby
21
22 DEPENDS += " \
23         ruby \
24         facter \
25         "
26
27 RDEPENDS_${PN} += " \
28         ruby \
29         facter \
30         puppet \
31         perl \
32         "
33
34 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
35
36 do_install_append () {
37         install -d -m 0755 ${D}/${datadir}/puppet/modules/create_resources
38         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/create_resources
39 }
40
41 FILES_${PN} += " ${datadir}"