Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppetlabs-concat_git.bb
1
2 DESCRIPTION = "Construct files from multiple fragments."
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7 PV = "2.2.0"
8 SRCREV = "fdf4a84534ccb1b9ae8ffb654c7e160a31e294ee"
9 PROTOCOL = "https"
10 BRANCH = "main"
11 S = "${WORKDIR}/git"
12
13 SRC_URI = "git://github.com/puppetlabs/puppetlabs-concat.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
14     file://puppetlabs-concat/Add-gemspec.patch \
15     "
16
17 inherit ruby
18
19 DEPENDS += " \
20         ruby \
21         facter \
22         "
23
24 RDEPENDS_${PN} += " \
25         ruby \
26         facter \
27         puppet \
28         perl \
29         "
30
31 RUBY_INSTALL_GEMS = "puppetlabs-concat-${PV}.gem"
32
33 do_install_append() {
34         install -d -m 0755 ${D}/${datadir}/puppet/modules/concat
35         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/concat
36 }
37
38 FILES_${PN} += " ${datadir}"