Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-staging_git.bb
1
2 SUMMARY = "Manages staging directory, along with download/extraction of compressed files."
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=cdbf8d74b765504fbdf8e154bb4458a1"
6
7 PV = "1.0.4"
8 SRCREV = "bc434a71e19aae54223d57c274e2e1a7f9546d5e"
9 PROTOCOL = "https"
10 BRANCH = "master"
11 S = "${WORKDIR}/git"
12
13 SRC_URI = " \
14         git://github.com/nanliu/puppet-staging;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
15         file://puppet-staging/Add-gemspec.patch \
16         "
17
18 inherit ruby
19
20 DEPENDS += " \
21         ruby \
22         facter \
23         "
24
25 RDEPENDS_${PN} += " \
26         ruby \
27         facter \
28         puppet \
29         perl \
30         "
31
32 RUBY_BUILD_GEMS = "nanliu-staging.gemspec"
33 RUBY_INSTALL_GEMS = "nanliu-staging-${PV}.gem"
34
35 do_install_append() {
36         install -d -m 0755 ${D}/${datadir}/puppet/modules/staging
37         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/staging
38 }
39
40 FILES_${PN} += " ${datadir}"