Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-puppi_git.bb
1
2 SUMMARY = "Installs and configures Puppi."
3 DESCRIPTION = " \
4         This module provides the Puppi libraries required by Example42 modules and, if explicitely included, the \
5         puppi command, its working environment, the defines and procedures to deploy applications.\
6         "
7
8 LICENSE = "Apache-2.0"
9 LIC_FILES_CHKSUM = "file://LICENSE;md5=a300b604c66de62cf6e923cca89c9d83"
10
11 PV = "2.2.3"
12 SRCREV = "c1c47f4edfd761d1bbde32a75da0c3fa7cc93a81"
13 PROTOCOL = "https"
14 BRANCH = "master"
15 S = "${WORKDIR}/git"
16
17 SRC_URI = " \
18         git://github.com/example42/puppi;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
19         file://${PN}/Add-gemspec.patch \
20         " 
21
22 inherit ruby 
23
24 DEPENDS += " \
25         ruby \
26         facter \
27         "
28
29 RDEPENDS_${PN} += " \
30         ruby \
31         facter \
32         puppet \
33         perl \
34         "
35
36 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
37
38 do_install_append() {
39         install -d -m 0755 ${D}/${datadir}/puppet/modules/puppi
40         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/puppi
41 }
42
43 FILES_${PN} += " ${datadir}"