Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-oslo_git.bb
1
2 SUMMARY = "The oslo module is a part of OpenStack intended to provide continuous integration testing and code review."
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=86e96afa80a52eedda5dccc1af36b4f2"
6
7 PV = "11.3.0"
8 SRCREV = "5ad200e9d8af200a8f50f86a2db4cf3f36ab2a4c"
9 PROTOCOL = "https"
10 S = "${WORKDIR}/git"
11
12 SRC_URI = "git://github.com/openstack/puppet-oslo.git;protocol=${PROTOCOL};rev=${SRCREV};nobranch=1 \
13         file://puppet-oslo/Add-gemspec.patch \
14         "
15
16 inherit ruby
17
18 DEPENDS += " \
19         ruby \
20         facter \
21         "
22
23 RDEPENDS_${PN} += " \
24         ruby \
25         facter \
26         puppet \
27         perl \
28         "
29
30 RUBY_INSTALL_GEMS = "puppet-oslo-${PV}.gem"
31
32 do_install_append() {
33         install -d -m 0755 ${D}/${datadir}/puppet/modules/oslo
34         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/oslo
35 }
36
37 FILES_${PN} += " ${datadir}"