Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-memcached_git.bb
1
2 SUMMARY = "Intended managing the entirety of horizon."
3 DESCRIPTION = " \
4         The horizon module is a thorough attempt to make Puppet capable of \
5         managing the entirety of horizon. Horizon is a fairly classic django \
6         application, which results in a fairly simply Puppet module.\
7         "
8
9 HOMEPAGE = "https://github.com/saz/puppet-memcached.git"
10 LICENSE = "Apache-2.0"
11 LIC_FILES_CHKSUM = "file://LICENSE;md5=1322039bbc8e3ff4e74252ec65303861"
12
13 PV = "3.0.2"
14 SRCREV = "c2a0b543dc28f34ab68e905ede3173b00246ddca"
15 PROTOCOL = "https"
16 BRANCH = "master"
17 S = "${WORKDIR}/git"
18
19 SRC_URI = " \
20         git://github.com/saz/puppet-memcached.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
21         file://puppet-memcached/Add-gemspec.patch \
22         "
23
24 inherit ruby
25
26 DEPENDS += " \
27         ruby \
28         facter \
29         "
30
31 RDEPENDS_${PN} += " \
32         ruby \
33         facter \
34         puppet \
35         perl \
36         "
37
38 RUBY_INSTALL_GEMS = "puppet-memcached-${PV}.gem"
39
40 do_install_append() { 
41         install -d -m 0755 ${D}/${datadir}/puppet/modules/memcached
42         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/memcached
43 }
44
45 FILES_${PN} += " ${datadir}"