Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-ldap_git.bb
1
2 SUMMARY = "OpenLDAP module for Puppet."
3
4 LICENSE = "GPLv2"
5 LIC_FILES_CHKSUM = "file://metadata.json;md5=4244fe391bee02e9ee7259aa7f8dda8b"
6
7 PV = "0.2.4"
8 SRCREV = "480f13af6d17d1d3fcf0dc7b4bd04b49fa4099e1"
9 PROTOCOL = "https"
10 BRANCH = "master"
11 S = "${WORKDIR}/git"
12
13 SRC_URI = " \
14         git://github.com/torian/puppet-ldap;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
15         file://puppet-ldap/Add-gemspec.patch \
16         "
17 inherit ruby 
18
19 DEPENDS += " \
20         ruby \
21         facter \
22         "
23
24 RDEPENDS_${PN} += " \
25         ruby \
26         facter \
27         puppet \
28         perl \
29         "
30
31 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
32
33 do_install_append() {
34         install -d -m 0755 ${D}/${datadir}/puppet/modules/ldap
35         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/ldap
36 }
37
38 FILES_${PN} += " ${datadir}"