Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-kmod_git.bb
1
2 SUMMARY = "Manage Linux kernel modules with Puppet"
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=0e5ccf641e613489e66aa98271dbe798"
6
7 PV = "2.1.0"
8 SRCREV = "0d69a96e8d0d3a08da0d5f476c733134df4fb9ee"
9 PROTOCOL = "https"
10 BRANCH = "master"
11 S = "${WORKDIR}/git"
12
13 SRC_URI = "git://github.com/camptocamp/puppet-kmod;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
14         file://${PN}/Add-gemspec.patch \
15         file://${PN}/persistent-module-load-poky.patch \
16         "
17
18 inherit ruby
19
20 DEPENDS += " \
21         ruby \
22         facter \
23         "
24
25 RDEPENDS_${PN} += " \
26         ruby \
27         facter \
28         puppet \
29         perl \
30         "
31
32 RUBY_BUILD_GEMS = "camptocamp-kmod.gemspec"
33 RUBY_INSTALL_GEMS = "camptocamp-kmod-${PV}.gem"
34
35 do_install_append() {
36         install -d -m 0755 ${D}/${datadir}/puppet/modules/kmod
37         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/kmod
38 }
39
40 FILES_${PN} += " ${datadir}"