Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-keystone_git.bbappend
1 inherit stx-metadata
2
3 STX_REPO = "integ"
4 STX_SUBPATH = "config/puppet-modules/openstack/${BP}/centos"
5
6 SRC_URI_STX += " \
7         file://patches/0001-pike-rebase-squash-titanium-patches.patch \
8         file://patches/0002-remove-the-Keystone-admin-app.patch \
9         file://patches/0003-remove-eventlet_bindhost-from-Keystoneconf.patch \
10         file://patches/0004-escape-special-characters-in-bootstrap.patch \
11         file://patches/0005-Add-support-for-fernet-receipts.patch \
12         file://patches/0006-update-Barbican-admin-secret-s-user-project-IDs-duri.patch \
13         file://patches/0007-update-for-openstackclient-Train-upgrade.patch \
14         "
15
16 SRC_URI += " \
17         file://${BPN}/puppet-keystone-specify-full-path-to-openrc.patch \
18         file://${BPN}/puppet-keystone-params.pp-fix-the-service-name.patch \
19         "
20
21 do_install_append () {
22         # fix the name of python-memcached
23         sed -i -e 's/python-memcache\b/python-memcached/' ${D}/${datadir}/puppet/modules/keystone/manifests/params.pp
24 }
25
26 RDEPENDS_${PN} += " \
27         python-memcached \
28         python-ldappool \
29         "
30
31 inherit openssl10