Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-horizon_git.bb
1
2 SUMMARY = "Intended managing the entirety of horizon."
3 DESCRIPTION = " \
4         The horizon module is a thorough attempt to make Puppet capable of \
5         managing the entirety of horizon. Horizon is a fairly classic django \
6         application, which results in a fairly simply Puppet module.\
7         "
8
9 # HOMEPAGE = "https://github.com/openstack/puppet-horizon"
10 LICENSE = "Apache-2.0"
11 LIC_FILES_CHKSUM = "file://LICENSE;md5=12a15a9ebddda7d856c783f745e5ee47"
12
13 PV = "11.5.0"
14 SRCREV = "d75706e38fdf63f9c3174a526a7d07799390dfeb"
15 PROTOCOL = "https"
16 S = "${WORKDIR}/git"
17
18 SRC_URI = "git://github.com/openstack/puppet-horizon.git;protocol=${PROTOCOL};rev=${SRCREV};nobranch=1 \
19         file://${PN}/Add-gemspec.patch \
20         "
21
22 inherit ruby
23
24 DEPENDS += " \
25         ruby \
26         facter \
27         "
28
29 RDEPENDS_${PN} += " \
30         ruby \
31         facter \
32         puppet \
33         perl \
34         "
35
36 RUBY_INSTALL_GEMS = "puppet-horizon-${PV}.gem"
37
38 do_install_append() { 
39         install -d -m 0755 ${D}/${datadir}/puppet/modules/horizon
40         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/horizon
41 }
42
43 FILES_${PN} += " ${datadir}"