Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-filemapper_git.bb
1
2 DESCRIPTION = "A Puppet module to map files to resources and back."
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=b43880e14353cbc12cf3981fb93a0944"
6
7 PV = "1.1.3"
8 SRCREV = "9b53310278e76827bbe12a36cc6470d77071abb2"
9 PROTOCOL = "https"
10 BRANCH = "master"
11 S = "${WORKDIR}/git"
12
13 SRC_URI = " \
14         git://github.com/adrienthebo/puppet-filemapper;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
15         file://${PN}/Add-gemspec.patch \
16         file://${PN}/metadata.json.patch \
17         " 
18
19 inherit ruby 
20
21 DEPENDS += " \
22         ruby \
23         facter \
24         "
25
26 RDEPENDS_${PN} += " \
27         ruby \
28         facter \
29         puppet \
30         perl \
31         "
32
33 RUBY_BUILD_GEMS = "adrien-filemapper.gemspec"
34 RUBY_INSTALL_GEMS = "adrien-filemapper-${PV}.gem"
35
36 do_install_append() {
37         install -d -m 0755 ${D}/${datadir}/puppet/modules/filemapper
38         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/filemapper
39 }
40
41 FILES_${PN} += " ${datadir}"