Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-etcd_git.bb
1
2 SUMMARY = "Installs and configures etcd"
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
6
7 PV = "1.11.0"
8 SRCREV = "f43e1292a9554766f799cd5a14b67cc19ce5b00e"
9 PROTOCOL = "https"
10 BRANCH = "master"
11 S = "${WORKDIR}/git"
12
13 SRC_URI = "git://github.com/cristifalcas/puppet-etcd;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
14         file://puppet-etcd/Add-gemspec.patch \
15         "
16
17 inherit ruby
18
19 DEPENDS += " \
20         ruby \
21         facter \
22         "
23
24 RDEPENDS_${PN} += " \
25         ruby \
26         facter \
27         puppet \
28         perl \
29         "
30
31 RUBY_INSTALL_GEMS = "puppet-etcd-${PV}.gem"
32
33 do_install_append() {
34         install -d -m 0755 ${D}/${datadir}/puppet/modules/etcd
35         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/etcd
36 }
37
38 FILES_${PN} += " ${datadir}"