Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-drbd_git.bb
1
2 DESCRIPTION = "puppet-drbd"
3
4 PV = "0.3.1"
5 SRCREV = "496b3ba9cd74a2d12636f9e90a718739a5451169"
6 PROTOCOL = "https"
7 BRANCH = "master"
8 S = "${WORKDIR}/git"
9
10 LICENSE = "Apache-2.0"
11
12 LIC_FILES_CHKSUM = "file://LICENSE;md5=6089b6bd1f0d807edb8bdfd76da0b038 "
13
14 SRC_URI = " \
15         git://github.com/voxpupuli/puppet-drbd;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
16         file://${PN}/Add-gemspec.patch \
17         "
18 inherit ruby 
19
20 DEPENDS += " \
21         ruby \
22         facter \
23         "
24
25 RDEPENDS_${PN} += " \
26         ruby \
27         facter \
28         puppet \
29         perl \
30         "
31
32 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
33
34 do_install_append() {
35         install -d -m 0755 ${D}/${datadir}/puppet/modules/drbd
36         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/drbd
37 }
38
39 FILES_${PN} += "${datadir}"