Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-collectd_git.bb
1
2 SUMMARY = "Puppet module for configuring collectd and plugins."
3
4 LICENSE = "Apache-2.0"
5 LIC_FILES_CHKSUM = "file://LICENSE;md5=03ff50a0bc4a15eb462d4129e89f9656"
6
7 PV = "5.1.0"
8 SRCREV = "f5a44db033c7cea9990c405519f70d18fc2b05c0"
9 PROTOCOL = "https"
10 BRANCH = "master"
11 S = "${WORKDIR}/git"
12
13 SRC_URI = "git://github.com/voxpupuli/puppet-collectd;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
14         file://${PN}/Add-gemspec.patch \
15         "
16
17 inherit ruby
18
19 DEPENDS += " \
20         ruby \
21         facter \
22         "
23
24 RDEPENDS_${PN} += " \
25         ruby \
26         facter \
27         puppet \
28         perl \
29         "
30
31 RUBY_INSTALL_GEMS = "${PN}-${PV}.gem"
32
33
34 do_install_append() {
35         install -d -m 0755 ${D}/${datadir}/puppet/modules/collectd
36         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/collectd
37 }
38
39 FILES_${PN} += " ${datadir}"