Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-certmonger_git.bb
1
2 SUMMARY = "Deprecated: Use saltedsignal/puppet-certmonger instead."
3 DESCRIPTION = " \
4         This puppet module allows you to request and manage certificates using certmonger. \
5         "
6
7 LICENSE = "Apache-2.0"
8 LIC_FILES_CHKSUM = "file://LICENSE;md5=5e8f921d6b978d3605270db1f39e199f"
9
10 PV = "1.1.1"
11 SRCREV = "1157a7e552d87696e80ed4ab54bf0608a1c5ffff"
12 PROTOCOL = "https"
13 BRANCH = "master"
14 S = "${WORKDIR}/git"
15
16 SRC_URI = "git://github.com/earsdown/puppet-certmonger.git;protocol=${PROTOCOL};rev=${SRCREV};branch=${BRANCH} \
17         file://puppet-certmonger/Add-gemspec.patch \
18         "
19
20 inherit ruby
21
22 DEPENDS += " \
23         ruby \
24         facter \
25         "
26
27 RDEPENDS_${PN} += " \
28         ruby \
29         facter \
30         puppet \
31         perl \
32         "
33
34 RUBY_INSTALL_GEMS = "puppet-certmonger-${PV}.gem"
35
36 do_install_append() {
37         install -d -m 0755 ${D}/${datadir}/puppet/modules/certmonger
38         tar -C ${S} -cf - --exclude "patches" --exclude "*.gem*" . | tar --no-same-owner -xf - -C ${D}/${datadir}/puppet/modules/certmonger
39 }
40
41 FILES_${PN} += " ${datadir}"