Revert "Revert "oran-shell-release: release image for F""
[pti/rtp.git] / meta-starlingx / meta-stx-cloud / recipes-support / puppet / puppet-ceph_git.bbappend
1 inherit stx-metadata
2
3 STX_REPO = "integ"
4 STX_SUBPATH = "config/puppet-modules/openstack/puppet-ceph-2.2.0/centos/patches"
5
6 SRC_URI_STX += " \
7         file://0001-Roll-up-TIS-patches.patch \
8         file://0002-Newton-rebase-fixes.patch \
9         file://0003-Ceph-Jewel-rebase.patch \
10         file://0004-US92424-Add-OSD-support-for-persistent-naming.patch \
11         file://0006-ceph-disk-prepare-invalid-data-disk-value.patch \
12         file://0007-Add-StarlingX-specific-restart-command-for-Ceph-moni.patch \
13         file://0008-ceph-mimic-prepare-activate-osd.patch \
14         file://0009-fix-ceph-osd-disk-partition-for-nvme-disks.patch \
15         file://0010-wipe-unprepared-disks.patch \
16         "
17
18 SRC_URI += " \
19         file://${BPN}/0005-Remove-puppetlabs-apt-as-ceph-requirement.patch \
20         file://${BPN}/0011-puppet-ceph-changes-for-poky-stx.patch \
21         "
22
23 inherit openssl10